<!DOCTYPE html>
<!--[if IEMobile 7]><html class="iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html lang="en" dir="ltr" prefix="fb: http://www.facebook.com/2008/fbml og: http://ogp.me/ns# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# sioc: http://rdfs.org/sioc/ns# sioct: http://rdfs.org/sioc/types# skos: http://www.w3.org/2004/02/skos/core# xsd: http://www.w3.org/2001/XMLSchema#"><!--<![endif]-->
<head profile="http://www.w3.org/1999/xhtml/vocab">
<meta charset="utf-8" />
<link rel="shortcut icon" href="https://www.clashmusic.com/sites/all/themes/clash_zen_2016/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="google-site-verification" content="IKrYr_iTjNJexiCDl0RTMV_BblM5G20UKP_0S6vimPY" />
<meta name="description" content="Crystal Murray Smashes Back With &#039;Too Much To Taste&#039;" />
<meta name="keywords" content="crystal Murray, too much to taste, listen, audio, show, clash, music, news" />
<meta name="generator" content="Drupal 7 (https://www.drupal.org)" />
<link rel="canonical" href="https://www.clashmusic.com/news/crystal-murray-smashes-back-with-too-much-to-taste" />
<link rel="shortlink" href="https://www.clashmusic.com/node/120794" />
<meta property="og:site_name" content="Clash Magazine" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.clashmusic.com/news/crystal-murray-smashes-back-with-too-much-to-taste" />
<meta property="og:title" content="Crystal Murray Smashes Back With &#039;Too Much To Taste&#039;" />
<meta property="og:description" content="Crystal Murray has shared her new single &#039;Too Much To Taste&#039; in full. The songwriter&#039;s new project &#039;Twisted Bases&#039; is incoming, featuring 10 tracks…" />
<meta property="og:image" content="https://www.clashmusic.com/sites/default/files/field/image/Crystal%20Murray.jpg" />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-1326618719024362",
    enable_page_level_ads: true
  });
</script><script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/clashmedia/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>

<script type="text/javascript" async=true>
(function() {
  var host = window.location.hostname;
  var element = document.createElement('script');
  var firstScript = document.getElementsByTagName('script')[0];
  var url = 'https://quantcast.mgr.consensu.org'
    .concat('/choice/', 'vCa2CymSVR230', '/', host, '/choice.js')
  var uspTries = 0;
  var uspTriesLimit = 3;
  element.async = true;
  element.type = 'text/javascript';
  element.src = url;

  firstScript.parentNode.insertBefore(element, firstScript);

  function makeStub() {
    var TCF_LOCATOR_NAME = '__tcfapiLocator';
    var queue = [];
    var win = window;
    var cmpFrame;

    function addFrame() {
      var doc = win.document;
      var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);

      if (!otherCMP) {
        if (doc.body) {
          var iframe = doc.createElement('iframe');

          iframe.style.cssText = 'display:none';
          iframe.name = TCF_LOCATOR_NAME;
          doc.body.appendChild(iframe);
        } else {
          setTimeout(addFrame, 5);
        }
      }
      return !otherCMP;
    }

    function tcfAPIHandler() {
      var gdprApplies;
      var args = arguments;

      if (!args.length) {
        return queue;
      } else if (args[0] === 'setGdprApplies') {
        if (
          args.length > 3 &&
          args[2] === 2 &&
          typeof args[3] === 'boolean'
        ) {
          gdprApplies = args[3];
          if (typeof args[2] === 'function') {
            args[2]('set', true);
          }
        }
      } else if (args[0] === 'ping') {
        var retr = {
          gdprApplies: gdprApplies,
          cmpLoaded: false,
          cmpStatus: 'stub'
        };

        if (typeof args[2] === 'function') {
          args[2](retr);
        }
      } else {
        queue.push(args);
      }
    }

    function postMessageEventHandler(event) {
      var msgIsString = typeof event.data === 'string';
      var json = {};

      try {
        if (msgIsString) {
          json = JSON.parse(event.data);
        } else {
          json = event.data;
        }
      } catch (ignore) {}

      var payload = json.__tcfapiCall;

      if (payload) {
        window.__tcfapi(
          payload.command,
          payload.version,
          function(retValue, success) {
            var returnMsg = {
              __tcfapiReturn: {
                returnValue: retValue,
                success: success,
                callId: payload.callId
              }
            };
            if (msgIsString) {
              returnMsg = JSON.stringify(returnMsg);
            }
            if (event && event.source && event.source.postMessage) {
              event.source.postMessage(returnMsg, '*');
            }
          },
          payload.parameter
        );
      }
    }

    while (win) {
      try {
        if (win.frames[TCF_LOCATOR_NAME]) {
          cmpFrame = win;
          break;
        }
      } catch (ignore) {}

      if (win === window.top) {
        break;
      }
      win = win.parent;
    }
    if (!cmpFrame) {
      addFrame();
      win.__tcfapi = tcfAPIHandler;
      win.addEventListener('message', postMessageEventHandler, false);
    }
  };

  makeStub();

  var uspStubFunction = function() {
    var arg = arguments;
    if (typeof window.__uspapi !== uspStubFunction) {
      setTimeout(function() {
        if (typeof window.__uspapi !== 'undefined') {
          window.__uspapi.apply(window.__uspapi, arg);
        }
      }, 500);
    }
  };

  var checkIfUspIsReady = function() {
    uspTries++;
    if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
      console.warn('USP is not accessible');
    } else {
      clearInterval(uspInterval);
    }
  };

  if (typeof window.__uspapi === 'undefined') {
    window.__uspapi = uspStubFunction;
    var uspInterval = setInterval(checkIfUspIsReady, 6000);
  }
})();
</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/22410272719/clashmusic.com', [[300, 250], [728, 90], [300, 600], [320, 50]], 'div-gpt-ad-1631461162057-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<title>Crystal Murray Smashes Back With 'Too Much To Taste' | News | Clash Magazine</title>
<meta name="google-site-verification" content="0qPmRr7CE6qXBsEcx2b1fetBl9sVXXlCWup_T4AUaBU" />
<meta name="MobileOptimized" content="width">
<meta name="HandheldFriendly" content="true">
<meta name="viewport" content="width=device-width">
<meta http-equiv="cleartype" content="on">
<style>
@import url("https://www.clashmusic.com/modules/system/system.base.css?r0yqta");
@import url("https://www.clashmusic.com/modules/system/system.messages.css?r0yqta");
@import url("https://www.clashmusic.com/modules/system/system.theme.css?r0yqta");
</style>
<style>
@import url("https://www.clashmusic.com/sites/all/modules/jquery_update/replace/ui/themes/base/minified/jquery.ui.core.min.css?r0yqta");
@import url("https://www.clashmusic.com/sites/all/modules/jquery_update/replace/ui/themes/base/minified/jquery.ui.theme.min.css?r0yqta");
</style>
<style>
@import url("https://www.clashmusic.com/modules/aggregator/aggregator.css?r0yqta");
@import url("https://www.clashmusic.com/modules/comment/comment.css?r0yqta");
@import url("https://www.clashmusic.com/modules/field/theme/field.css?r0yqta");
@import url("https://www.clashmusic.com/modules/node/node.css?r0yqta");
@import url("https://www.clashmusic.com/modules/search/search.css?r0yqta");
@import url("https://www.clashmusic.com/modules/user/user.css?r0yqta");
@import url("https://www.clashmusic.com/modules/forum/forum.css?r0yqta");
@import url("https://www.clashmusic.com/sites/all/modules/views/css/views.css?r0yqta");
</style>
<style>
@import url("https://www.clashmusic.com/sites/all/modules/ctools/css/ctools.css?r0yqta");
@import url("https://www.clashmusic.com/sites/all/modules/panels/css/panels.css?r0yqta");
@import url("https://www.clashmusic.com/sites/all/themes/clash_zen_2016/layouts/clash/../../css/panels/clash_article.css?r0yqta");
@import url("https://www.clashmusic.com/sites/all/modules/ctools/css/modal.css?r0yqta");
@import url("https://www.clashmusic.com/sites/all/modules/clash_ajax_register/css/ajax-register.css?r0yqta");
@import url("https://www.clashmusic.com/sites/all/modules/panels/plugins/layouts/twocol/twocol.css?r0yqta");
@import url("https://www.clashmusic.com/sites/all/modules/custom_search/custom_search.css?r0yqta");
</style>
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Droid+Serif:400,700,400italic,700italic|Questrial" media="all" />
<style>
@import url("https://www.clashmusic.com/sites/all/themes/clash_zen_2016/css/clash_zen.css?r0yqta");
@import url("https://www.clashmusic.com/sites/all/themes/clash_zen_2016/css/custom.css?r0yqta");
@import url("https://www.clashmusic.com/sites/all/themes/clash_zen_2016/css/overrides/galleryformatter.css?r0yqta");
</style>
<script src="https://www.clashmusic.com/sites/all/modules/jquery_update/replace/jquery/1.10/jquery.min.js?v=1.10.2"></script>
<script src="https://www.clashmusic.com/misc/jquery-extend-3.4.0.js?v=1.10.2"></script>
<script src="https://www.clashmusic.com/misc/jquery-html-prefilter-3.5.0-backport.js?v=1.10.2"></script>
<script src="https://www.clashmusic.com/misc/jquery.once.js?v=1.2"></script>
<script>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};</script>
<script src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script src="https://www.clashmusic.com/misc/drupal.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/modules/jquery_update/replace/ui/ui/minified/jquery.ui.core.min.js?v=1.10.2"></script>
<script>googletag.slots["mrec_top"] = googletag.defineSlot("22410272719/clashmusic.com", [300, 250], "dfp-ad-mrec_top")
  .addService(googletag.pubads())
  .setTargeting("pos", "1");</script>
<script>googletag.slots["mpu_top"] = googletag.defineSlot("22410272719/clashmusic.com", [300, 600], "dfp-ad-mpu_top")
  .addService(googletag.pubads())
  .setTargeting("pos", "1");</script>
<script src="https://www.clashmusic.com/sites/all/modules/jquery_update/replace/ui/external/jquery.cookie.js?v=67fb34f6a866c40d0570"></script>
<script src="https://www.clashmusic.com/sites/all/modules/jquery_update/replace/misc/jquery.form.min.js?v=2.69"></script>
<script>var mapping = googletag.sizeMapping()
  .addSize([360, 640], [320, 50])
  .addSize([1024, 768], [728, 90])
  .addSize([414, 736], [528, 90])
  .build();
googletag.slots["clone_of_leaderboard__op"] = googletag.defineSlot("22410272719/clashmusic.com", [320, 50], "dfp-ad-clone_of_leaderboard__op")
  .addService(googletag.pubads())
  .setTargeting("pos", "1")
  .defineSizeMapping(mapping);</script>
<script src="https://www.clashmusic.com/misc/ajax.js?v=7.82"></script>
<script src="https://www.clashmusic.com/sites/all/modules/jquery_update/js/jquery_update.js?v=0.0.1"></script>
<script>googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().setTargeting("CID", "120794");
  googletag.pubads().setTargeting("path", "news/crystal-murray-smashes-back-with-too-much-to-taste");
  googletag.pubads().setTargeting("page", "www.clashmusic.com/news/crystal-murray-smashes-back-with-too-much-to-taste");
});

googletag.enableServices();</script>
<script src="https://www.clashmusic.com/sites/all/modules/custom_search/js/custom_search.js?r0yqta"></script>
<script src="https://www.clashmusic.com/misc/progress.js?v=7.82"></script>
<script src="https://www.clashmusic.com/sites/all/modules/ctools/js/modal.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/modules/clash_ajax_register/js/ajax-register.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/modules/dfp_lazy_load/js/jquery.waypoints.min.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/modules/dfp_lazy_load/js/inview.min.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/themes/clash_zen_2016/js/modernizr.custom.81183.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/themes/clash_zen_2016/js/jquery.masonry.min.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/themes/clash_zen_2016/js/swfobject.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/themes/clash_zen_2016/js/jquery.flexslider-min.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/themes/clash_zen_2016/js/jquery.cycle.lite.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/themes/clash_zen_2016/js/script.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/themes/clash_zen_2016/js/menu-block.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/themes/clash_zen_2016/js/custom.js?r0yqta"></script>
<script>jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"clash_zen_2016","theme_token":"N8PkA4a4tnXR8w68sTqJi4g_6gaR6mhw-JroIGqp3AA","jquery_version":"1.10","js":{"sites\/all\/modules\/jquery_update\/replace\/jquery\/1.10\/jquery.min.js":1,"misc\/jquery-extend-3.4.0.js":1,"misc\/jquery-html-prefilter-3.5.0-backport.js":1,"misc\/jquery.once.js":1,"3":1,"https:\/\/www.googletagservices.com\/tag\/js\/gpt.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/jquery_update\/replace\/ui\/ui\/minified\/jquery.ui.core.min.js":1,"0":1,"1":1,"sites\/all\/modules\/jquery_update\/replace\/ui\/external\/jquery.cookie.js":1,"sites\/all\/modules\/jquery_update\/replace\/misc\/jquery.form.min.js":1,"2":1,"misc\/ajax.js":1,"sites\/all\/modules\/jquery_update\/js\/jquery_update.js":1,"4":1,"sites\/all\/modules\/custom_search\/js\/custom_search.js":1,"misc\/progress.js":1,"sites\/all\/modules\/ctools\/js\/modal.js":1,"sites\/all\/modules\/clash_ajax_register\/js\/ajax-register.js":1,"sites\/all\/modules\/dfp_lazy_load\/js\/jquery.waypoints.min.js":1,"sites\/all\/modules\/dfp_lazy_load\/js\/inview.min.js":1,"sites\/all\/themes\/clash_zen_2016\/js\/modernizr.custom.81183.js":1,"sites\/all\/themes\/clash_zen_2016\/js\/jquery.masonry.min.js":1,"sites\/all\/themes\/clash_zen_2016\/js\/swfobject.js":1,"sites\/all\/themes\/clash_zen_2016\/js\/jquery.flexslider-min.js":1,"sites\/all\/themes\/clash_zen_2016\/js\/jquery.cycle.lite.js":1,"sites\/all\/themes\/clash_zen_2016\/js\/script.js":1,"sites\/all\/themes\/clash_zen_2016\/js\/menu-block.js":1,"sites\/all\/themes\/clash_zen_2016\/js\/custom.js":1}},"custom_search":{"form_target":"_self","solr":1},"better_exposed_filters":{"views":{"most_popular_articles_sidebar":{"displays":{"default":{"filters":[]}}},"related_artist_block":{"displays":{"block":{"filters":[]}}}}},"CToolsModal":{"loadingText":"Loading...","closeText":"Close Window","closeImage":"\u003Cimg typeof=\u0022foaf:Image\u0022 src=\u0022https:\/\/www.clashmusic.com\/sites\/all\/modules\/ctools\/images\/icon-close-window.png\u0022 alt=\u0022Close window\u0022 title=\u0022Close window\u0022 \/\u003E","throbber":"\u003Cimg typeof=\u0022foaf:Image\u0022 src=\u0022https:\/\/www.clashmusic.com\/sites\/all\/modules\/ctools\/images\/throbber.gif\u0022 alt=\u0022Loading\u0022 title=\u0022Loading...\u0022 \/\u003E"},"ctools-ajax-register-style":{"modalSize":{"type":"fixed","width":410,"height":140,"contentRight":30,"contentBottom":0},"modalOptions":{"opacity":0.5,"background-color":"#ffffff"},"closeText":"","throbber":"\u003Cimg typeof=\u0022foaf:Image\u0022 src=\u0022https:\/\/www.clashmusic.com\/sites\/all\/modules\/clash_ajax_register\/images\/ajax-loader.gif\u0022 alt=\u0022\u0022 \/\u003E","animation":"fadeIn","animationSpeed":"fast"},"urlIsAjaxTrusted":{"\/news\/crystal-murray-smashes-back-with-too-much-to-taste":true},"dfp_lazy_load":{"mrec_lazy_load":"mrec_lazy_load","leaderboard__op":0,"leaderboard__bottom":0,"mrec_top":0,"mrec":0,"mpu_top":0}});</script>
<!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
<script>
        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
        ga('create', 'UA-52108155-1', 'auto');
        ga('send', 'pageview');
    </script>
<meta property="fb:app_id" content="439703296071140" />
<script src='//www.google.com/recaptcha/api/js/recaptcha_ajax.js'></script>

<script type="text/javascript">(function(i,m,p,a,c,t){c.ire_o=p;c[p]=c[p]||function(){(c[p].a=c[p].a||[]).push(arguments)};t=a.createElement(m);var z=a.getElementsByTagName(m)[0];t.async=1;t.src=i;z.parentNode.insertBefore(t,z)})('//d.impactradius-event.com/P-A2072800-69a1-4346-a378-a9d325ea89a61.js','script','impactStat',document,window);impactStat('transformLinks');impactStat('trackImpression');</script>
<script data-ad-client="ca-pub-1326618719024362" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/c0b09939b08d0170754b8ac8a/99485e8847b82418007f04648.js");</script>
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async=""></script>
<script>
  window.OneSignal = window.OneSignal || [];
  OneSignal.push(function() {
    OneSignal.init({
      appId: "c3a995cf-9a86-4990-b0a9-f595309c6a2d",
    });
  });
</script>
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-120794 node-type-article section-news page-panels">
<p id="skip-link"><a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a></p>
<div id="page">
<aside id="leaderboard">
<div class="region region-leaderboard">
<div id="block-dfp-clone-of-leaderboard-op" class="block block-dfp first last odd">
<div id="dfp-ad-clone_of_leaderboard__op-wrapper" class="dfp-tag-wrapper">
<div id="dfp-ad-clone_of_leaderboard__op" class="dfp-tag-wrapper">
<script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-clone_of_leaderboard__op");
    });
  </script>
</div>
</div>
</div>
</div>
</aside>
<div id="page-meta">
</div>
<header id="header" role="banner">
<div id="scroll-to-nav"></div>
</header>
<div id="navigation">
<div class="inner">
<nav id="main-menu" role="navigation">
<h2 class="element-invisible">Main menu</h2><ul class="links inline"><li class="menu-646 first"><a href="/">Home</a></li>
<li class="menu-647 active-trail"><a href="/news" class="active-trail">News</a></li>
<li class="menu-642"><a href="/features">Features</a></li>
<li class="menu-645"><a href="/fashion">Fashion</a></li>
<li class="menu-643"><a href="/reviews">Reviews</a></li>
<li class="menu-1966"><a href="/live">Live</a></li>
<li class="menu-1314"><a href="/next-wave">Next&nbsp;Wave</a></li>
<li class="menu-644"><a href="/videos">Videos</a></li>
<li class="menu-1331"><a href="/magazine" title="Find out about our latest issue and buy copies of Clash magazine">Magazine</a></li>
<li class="menu-1889"><a href="http://clash-magazine.myshopify.com" title="Buy back issues of Clash magazine" target="_blank">Shop</a></li>
<li class="menu-1971"><a href="/film">Film</a></li>
<li class="menu-1134 last"><a href="/win">Win</a></li>
</ul> <span class="justifier"></span>
</nav>
<div class="header__region region region-header">
<div id="block-block-90" class="block block-block first odd">
<p><a href="/"><img src="/sites/all/themes/clash_zen/images/clash-logo.png" /></a></p>
</div>
<div id="block-menu-menu-header-left" class="block block-menu even" role="navigation">
<h2 class="block__title block-title">Header Left</h2>
<ul class="menu"><li class="menu__item is-leaf first last leaf sections"><a href="/" class="menu__link sections">Sections</a></li>
</ul>
<button class="hamburger hamburger--elastic js-hamburger" type="button" aria-label="Menu" aria-controls="navigation">
<span class="hamburger-box">
<span class="hamburger-inner"></span>
</span>
</button>
</div>
<div id="block-menu-menu-header-right" class="block block-menu odd" role="navigation">
<h2 class="block__title block-title">Header Right</h2>
<ul class="menu"><li class="menu__item is-leaf first leaf tickets"><a href="https://shops.ticketmasterpartners.com/clash-magazine" class="menu__link">Tickets</a></li>
<li class="menu__item is-leaf leaf buy-clash"><a href="http://clash-magazine.myshopify.com" class="menu__link">Buy Clash</a></li>
<li class="menu__item is-leaf leaf sign-in-up"><a href="/user" class="menu__link">Sign In/Up</a></li>
<li class="menu__item is-leaf last leaf search"><a href="/search" class="menu__link">Search</a></li>
</ul>
</div>
<div id="block-clash-ajax-register-clash-ajax-register-block" class="block block-clash-ajax-register even">
<div class="item-list"><ul class="ajax-register-links inline"><li class="first"><a href="/clash_ajax_register/login/nojs" class="ctools-use-modal ctools-modal-ctools-ajax-register-style" title="Login">Sign in</a></li>
<li>/</li>
<li class="last"><a href="/clash_ajax_register/register/nojs" class="ctools-use-modal ctools-modal-ctools-ajax-register-style" title="Register">Register</a></li>
</ul></div>
</div>
<div id="block-search-form" class="block block-search odd" role="search">
<form class="search-form" role="search" action="/news/crystal-murray-smashes-back-with-too-much-to-taste" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
<h2 class="element-invisible">Search form</h2>
<div class="form-item form-type-textfield form-item-search-block-form">
<label class="element-invisible" for="edit-search-block-form--2">Search ClashMusic.com </label>
<input title="Enter the terms you wish to search for." class="custom-search-box form-text" placeholder="Search" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-442eCX7IYqq16wajf4H_QVGNb5eK5jVKXsqr2deunX4" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>
</div>
<div id="block-panels-mini-menu-block-mini-panel" class="block block-panels-mini last even">
<div class="panel-display panel-2col clearfix" id="mini-panel-menu_block_mini_panel">
<div class="panel-panel panel-col-first">
<div class="inside"><div class="panel-pane pane-block pane-search-form search-form">
<form class="search-form" role="search" action="/news/crystal-murray-smashes-back-with-too-much-to-taste" method="post" id="search-block-form--2" accept-charset="UTF-8"><div><div class="container-inline">
<h2 class="element-invisible">Search form</h2>
<div class="form-item form-type-textfield form-item-search-block-form">
<label class="element-invisible" for="edit-search-block-form--4">Search ClashMusic.com </label>
<input title="Enter the terms you wish to search for." class="custom-search-box form-text" placeholder="Search" type="text" id="edit-search-block-form--4" name="search_block_form" value="" size="15" maxlength="128" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-QhgTUv66MpttWIM51eLwC7o22n-KLaZuQzuPbP9dYq4" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>
</div>
<div class="panel-pane pane-block pane-system-main-menu panel-pane pane-block pane-system-main-menu">
<ul class="menu"><li class="menu__item is-leaf first leaf home"><a href="/" class="menu__link">Home</a></li>
<li class="menu__item is-expanded is-active-trail expanded active-trail news"><a href="/news" class="menu__link is-active-trail active-trail">News</a><ul class="menu"><li class="menu__item is-leaf is-active-trail first last leaf active-trail crystal-murray-smashes-back-with-039-too-much-to-taste-039 crystal-murray-smashes-back-with-039-too-much-to-taste-039"><a href="/news/crystal-murray-smashes-back-with-too-much-to-taste" class="menu__link is-active-trail menu-position-link active-trail active">Crystal Murray Smashes Back With &#039;Too Much To Taste&#039;</a></li>
</ul></li>
<li class="menu__item is-leaf leaf features"><a href="/features" class="menu__link">Features</a></li>
<li class="menu__item is-leaf leaf fashion"><a href="/fashion" class="menu__link">Fashion</a></li>
<li class="menu__item is-leaf leaf reviews"><a href="/reviews" class="menu__link">Reviews</a></li>
<li class="menu__item is-leaf leaf live"><a href="/live" class="menu__link">Live</a></li>
<li class="menu__item is-leaf leaf next-wave"><a href="/next-wave" class="menu__link">Next Wave</a></li>
<li class="menu__item is-leaf leaf videos"><a href="/videos" class="menu__link">Videos</a></li>
<li class="menu__item is-leaf leaf magazine"><a href="/magazine" title="Find out about our latest issue and buy copies of Clash magazine" class="menu__link">Magazine</a></li>
<li class="menu__item is-leaf leaf shop"><a href="http://clash-magazine.myshopify.com" title="Buy back issues of Clash magazine" target="_blank" class="menu__link">Shop</a></li>
<li class="menu__item is-leaf leaf film"><a href="/film" class="menu__link">Film</a></li>
<li class="menu__item is-leaf last leaf win"><a href="/win" class="menu__link">Win</a></li>
</ul>
</div>
</div>
</div>
<div class="panel-panel panel-col-last">
<div class="inside"></div>
</div>
</div>
<div class="buttonWrap">
<a href="https://clash-magazine.myshopify.com/" class="buyClashMag">Buy Clash</a>
<a href="https://shops.ticketmasterpartners.com/clash-magazine" class="buyClashMag">Tickets</a>
</div>
<hr>
<div class="addthis_custom_follow">
</div>
</div>
</div>
</div>
</div>
<div id="content-nav-wrap">
<section id="main">
<div id="content" class="column clash-main" role="main">
<a id="main-content"></a>
<div>
<div></div>
</div>
<div class="panel-clash-article clearfix panel-display">
<div class="panel-col-top panel-panel">
<div class="inside"><div class="panel-pane pane-entity-field pane-node-field-image">
<div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="og:image rdfs:seeAlso" resource="https://www.clashmusic.com/sites/default/files/field/image/Crystal%20Murray.jpg"><div class="article-image"><img typeof="foaf:Image" src="/sites/default/files/field/image/Crystal%20Murray.jpg" width="1160" height="1454" alt="" title="Crystal Murray Smashes Back With &#039;Too Much To Taste&#039;" /></div></div></div></div>
</div>
</div>
</div>
<div class="centre-wrapper clearfix">
<div class="panel-col-main panel-panel">
<div class="inside"><div class="panel-pane pane-node-title">
<h2><a href="/news/crystal-murray-smashes-back-with-too-much-to-taste" class="active">Crystal Murray Smashes Back With &#039;Too Much To Taste&#039;</a></h2>
</div>
<div class="panel-pane pane-entity-field pane-node-field-article-subtitle">
<div class="field field-name-field-article-subtitle field-type-text field-label-hidden"><div class="field-items"><div class="field-item even">Her ultra-colourful new video is online now...</div></div></div>
</div>
<div class="panel-pane pane-node-author article-meta">
<span class="username" xml:lang="" about="/users/robin-murray" typeof="sioc:UserAccount" property="foaf:name" datatype="">Robin Murray</span>
</div>
<div class="panel-pane pane-entity-field pane-node-field-section article-meta">
<div class="field field-name-field-section field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news-0" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">News</a></div></div></div>
</div>
<div class="panel-pane pane-node-created article-meta">
14 · 10 · 2021
</div>
<div class="panel-pane pane-block pane-block-91 addthis-article">
<div class="addthis_custom_sharing"></div>
</div>
<div class="panel-pane pane-node-content">
<article id="article-full" class="node-120794 node node-article node-promoted view-mode-full clearfix" about="/news/crystal-murray-smashes-back-with-too-much-to-taste" typeof="sioc:Item foaf:Document">
<header>
<h1 class="node__title node-title"></h1>
<span property="dc:title" content="" class="rdf-meta element-hidden"></span><span property="sioc:num_replies" content="0" datatype="xsd:integer" class="rdf-meta element-hidden"></span>
<div class="article-meta">
<a href="/users/robin-murray">Robin Murray</a> /
<div class="field field-name-field-section field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">News</a></div></div></div> /
/
14 · 10 · 2021 <div class="comment-count-bubble">0</div>
</div>
</header>
<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><strong>Crystal Murray</strong> has shared her new single 'Too Much To Taste' in full.</p><p>The songwriter's new project 'Twisted Bases' is incoming, featuring 10 tracks that build on those frenetic early singles.</p><p>Out in February, the project is led by a crunching new single, one laced with colour and energy.</p><p>'Too Much To Taste' erupts from the speakers, and it's accompanied by a blistering new visualiser.</p><p>Directed by Alma de Ricou and Manon Engel, it was in shot in Paris at La fête à Neuneu.</p><p>Tune in now.</p><p><iframe allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" frameborder="0" height="315" src="https://www.youtube.com/embed/XrhEEnnoOOY" title="YouTube video player" width="560"></iframe></p><p>- - -</p></div></div></div><div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even" rel="dc:subject"><a href="/crystal-murray" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Crystal Murray</a></div></div></div>
</article>
</div>
<div class="panel-pane pane-block pane-block-37">
-
</div>
<div class="panel-pane pane-block pane-block-106">
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'alternating-thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
</div>
<div class="panel-pane pane-block pane-block-98">
<p><a href="https://theclashshop.com/"><img alt="" src="/sites/default/files/buy%20clash%20magazine%204.gif" style="border-width: 1px; border-style: solid;" width="99.6%;" /></a></p>
</div>
<div class="panel-pane pane-block pane-block-97">
<p><a href="https://vero.co/clashmagazine" target="_blank"><img alt="Join us on VERO" src="/sites/default/files/join%20us%20on%20vero%202.gif" style="border-width: 1px; border-style: solid;" width="99.6%;" /></a></p>
</div>
<div class="panel-pane pane-block pane-block-96">
<div style="border:1px; border-style:solid; border-color:#000000; padding: 1em;background-color: black; color:white;">
Join the Clash mailing list for up to the minute music, fashion and film news.

<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#000; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://clashmusic.us13.list-manage.com/subscribe/post?u=c0b09939b08d0170754b8ac8a&amp;id=8cb9b01512" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL"></label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_c0b09939b08d0170754b8ac8a_8cb9b01512" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>

</div>
<p></p>
</div>
<div class="panel-pane pane-block pane-block-91">
<div class="addthis_custom_sharing"></div>
</div>
</div>
</div>
<div class="panel-col-aside panel-panel">
<div class="inside"><div class="panel-pane pane-block pane-block-89 addthis-follow">
<h2 class="pane-title">
Follow Clash: </h2>
<div class="addthis_custom_follow"></div>
</div>
<div class="panel-pane pane-block pane-dfp-mrec-top">
<div id="dfp-ad-mrec_top-wrapper" class="dfp-tag-wrapper">
<div id="dfp-ad-mrec_top" class="dfp-tag-wrapper">
<script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-mrec_top");
    });
  </script>
</div>
</div>
</div>
<div class="panel-pane pane-views pane-most-popular-articles-sidebar">
<div class="view view-most-popular-articles-sidebar view-id-most_popular_articles_sidebar view-display-id-default clash-sidebar view-dom-id-52f8c825f20f0208c9ace0da67f9ccfa">
<div class="view-header">
<h2 class="readNextTitle hideInTeaser">Read this next</h2> </div>
<div class="view-content">
<ul class="article-preview-list clearfix"> <li class="views-row views-row-1 views-row-odd views-row-first article-preview-item"><div id="node-teaser-120770" class="article-teaser node node-article node-promoted node-teaser clearfix" about="/features/its-not-bad-to-change-yourself-itzy-interviewed" typeof="sioc:Item foaf:Document">
<div class="article-meta">
<span class="meta-section"><div class="field field-name-field-section field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/features" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Features</a></div></div></div></span>
<span class="meta-author"> / <a href="/author/ClashMusic">ClashMusic</a></span>
<span class="meta-date"> / <span property="dc:date dc:created" content="2021-10-13T14:50:29+01:00" datatype="xsd:dateTime">13 · 10 · 2021</span></span>
</div>
<div class="teaser-image">
<a href="/features/its-not-bad-to-change-yourself-itzy-interviewed"><img typeof="foaf:Image" src="/sites/default/files/styles/preview_mobile/public/field/image/itzy_crazy_in_love_concept_all_group.jpg?itok=wTsTCMsN" alt="" /></a> </div>
<h2 class="node__title node-title"><a href="/features/its-not-bad-to-change-yourself-itzy-interviewed">&quot;It&#039;s Not Bad To Change Yourself!&quot; ITZY Interviewed</a></h2>
<span property="dc:title" content="&quot;It&#039;s Not Bad To Change Yourself!&quot; ITZY Interviewed" class="rdf-meta element-hidden"></span><span property="sioc:num_replies" content="0" datatype="xsd:integer" class="rdf-meta element-hidden"></span></div>
</li>
<li class="views-row views-row-2 views-row-even article-preview-item"><div id="node-teaser-120796" class="article-teaser node node-article node-promoted node-teaser clearfix" about="/features/always-looking-for-hope-nao-interviewed" typeof="sioc:Item foaf:Document">
<div class="article-meta">
<span class="meta-section"><div class="field field-name-field-section field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/features" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Features</a></div></div></div></span>
<span class="meta-author"> / <a href="/author/ClashMusic">ClashMusic</a></span>
<span class="meta-date"> / <span property="dc:date dc:created" content="2021-10-14T15:57:31+01:00" datatype="xsd:dateTime">14 · 10 · 2021</span></span>
</div>
<div class="teaser-image">
<a href="/features/always-looking-for-hope-nao-interviewed"><img typeof="foaf:Image" src="/sites/default/files/styles/preview_mobile/public/field/image/Screenshot-2021-07-23-at-16.28.18.png?itok=Aa0V2uI6" alt="" /></a> </div>
<h2 class="node__title node-title"><a href="/features/always-looking-for-hope-nao-interviewed">&quot;Always Looking For Hope&quot; NAO Interviewed</a></h2>
<span property="dc:title" content="&quot;Always Looking For Hope&quot; NAO Interviewed" class="rdf-meta element-hidden"></span><span property="sioc:num_replies" content="0" datatype="xsd:integer" class="rdf-meta element-hidden"></span></div>
</li>
<li class="views-row views-row-3 views-row-odd views-row-last article-preview-item"><div id="node-teaser-120789" class="article-teaser node node-article node-promoted node-teaser clearfix" about="/features/mogwais-stuart-braithwaite-in-conversation-with-clark" typeof="sioc:Item foaf:Document">
<div class="article-meta">
<span class="meta-section"><div class="field field-name-field-section field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/features" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Features</a></div></div></div></span>
<span class="meta-author"> / <a href="/author/ClashMusic">ClashMusic</a></span>
<span class="meta-date"> / <span property="dc:date dc:created" content="2021-10-14T13:11:35+01:00" datatype="xsd:dateTime">14 · 10 · 2021</span></span>
</div>
<div class="teaser-image">
<a href="/features/mogwais-stuart-braithwaite-in-conversation-with-clark"><img typeof="foaf:Image" src="/sites/default/files/styles/preview_mobile/public/field/image/20201208-Clark-_Nov_2020_sofa2_Photo_Credit_Eva_Vermandel---Landscape-Crop.jpg?itok=otscI687" alt="" /></a> </div>
<h2 class="node__title node-title"><a href="/features/mogwais-stuart-braithwaite-in-conversation-with-clark">Mogwai&#039;s Stuart Braithwaite In Conversation With Clark</a></h2>
<span property="dc:title" content="Mogwai&#039;s Stuart Braithwaite In Conversation With Clark" class="rdf-meta element-hidden"></span><span property="sioc:num_replies" content="0" datatype="xsd:integer" class="rdf-meta element-hidden"></span></div>
</li>
</ul> </div>
</div>
</div>
<div class="panel-pane pane-block pane-dfp-mpu-top">
<div id="dfp-ad-mpu_top-wrapper" class="dfp-tag-wrapper">
<div id="dfp-ad-mpu_top" class="dfp-tag-wrapper">
<script type="text/javascript">
    googletag.cmd.push(function() {
      googletag.display("dfp-ad-mpu_top");
    });
  </script>
</div>
</div>
</div>
<div class="panel-pane pane-views pane-related-artist-block">
<div class="view view-related-artist-block view-id-related_artist_block view-display-id-block view-dom-id-4bc54771ae0f89fdb8f8e2fac2a7eb24">
<div class="view-content">
<div class="item-list"> <ul> <li class="views-row views-row-1 views-row-odd views-row-first"><div id="node-teaser-118910" class="article-teaser node node-article node-promoted node-teaser clearfix" about="/news/crystal-murray-takes-control-with-boss" typeof="sioc:Item foaf:Document">
<div class="article-meta">
<span class="meta-section"><div class="field field-name-field-section field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">News</a></div></div></div></span>
<span class="meta-author"> / <a href="/author/Robin%20Murray">Robin Murray</a></span>
<span class="meta-date"> / <span property="dc:date dc:created" content="2021-06-08T10:18:19+01:00" datatype="xsd:dateTime">08 · 06 · 2021</span></span>
</div>
<div class="teaser-image">
<a href="/news/crystal-murray-takes-control-with-boss"><img typeof="foaf:Image" src="/sites/default/files/styles/preview_mobile/public/field/image/COLORSxSTUDIOS_AnnouncePic_CrystalMurray.jpg?itok=p6buRrpC" alt="" /></a> </div>
<h2 class="node__title node-title"><a href="/news/crystal-murray-takes-control-with-boss">Crystal Murray Takes Control With &#039;Boss&#039;</a></h2>
<span property="dc:title" content="Crystal Murray Takes Control With &#039;Boss&#039;" class="rdf-meta element-hidden"></span><span property="sioc:num_replies" content="0" datatype="xsd:integer" class="rdf-meta element-hidden"></span></div>
</li>
<li class="views-row views-row-2 views-row-even"><div id="node-teaser-116467" class="article-teaser node node-article node-promoted node-teaser clearfix" about="/news/crystal-murray-shares-intimate-gggb-visualiser" typeof="sioc:Item foaf:Document">
<div class="article-meta">
<span class="meta-section"><div class="field field-name-field-section field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">News</a></div></div></div></span>
<span class="meta-author"> / <a href="/author/Robin%20Murray">Robin Murray</a></span>
<span class="meta-date"> / <span property="dc:date dc:created" content="2020-12-10T13:00:25+00:00" datatype="xsd:dateTime">10 · 12 · 2020</span></span>
</div>
<div class="teaser-image">
<a href="/news/crystal-murray-shares-intimate-gggb-visualiser"><img typeof="foaf:Image" src="/sites/default/files/styles/preview_mobile/public/field/image/crystal%20murray_0.jpg?itok=6hj0rF7p" alt="" /></a> </div>
<h2 class="node__title node-title"><a href="/news/crystal-murray-shares-intimate-gggb-visualiser">Crystal Murray Shares Intimate &#039;GGGB&#039; Visualiser</a></h2>
<span property="dc:title" content="Crystal Murray Shares Intimate &#039;GGGB&#039; Visualiser" class="rdf-meta element-hidden"></span><span property="sioc:num_replies" content="0" datatype="xsd:integer" class="rdf-meta element-hidden"></span></div>
</li>
<li class="views-row views-row-3 views-row-odd views-row-last"><div id="node-teaser-113295" class="article-teaser node node-article node-promoted node-teaser clearfix" about="/news/track-of-the-day-205-crystal-murray" typeof="sioc:Item foaf:Document">
<div class="article-meta">
<span class="meta-section"><div class="field field-name-field-section field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/news" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">News</a></div></div></div></span>
<span class="meta-author"> / <a href="/author/Robin%20Murray">Robin Murray</a></span>
<span class="meta-date"> / <span property="dc:date dc:created" content="2020-05-20T11:10:40+01:00" datatype="xsd:dateTime">20 · 05 · 2020</span></span>
</div>
<div class="teaser-image">
<a href="/news/track-of-the-day-205-crystal-murray"><img typeof="foaf:Image" src="/sites/default/files/styles/preview_mobile/public/field/image/crystal%20murray.jpg?itok=olS_1Sw6" alt="" /></a> </div>
<h2 class="node__title node-title"><a href="/news/track-of-the-day-205-crystal-murray">Track Of The Day 20/5 - Crystal Murray</a></h2>
<span property="dc:title" content="Track Of The Day 20/5 - Crystal Murray" class="rdf-meta element-hidden"></span><span property="sioc:num_replies" content="0" datatype="xsd:integer" class="rdf-meta element-hidden"></span></div>
</li>
</ul></div> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section id="explore-footer">
<div class="region region-explore-footer">
<div id="block-menu-menu-footer-menu" class="block block-menu first last odd" role="navigation">
<ul class="menu"><li class="menu__item is-leaf first leaf site-user-terms"><a href="/page/terms-and-conditions" title="" class="menu__link">Site User Terms</a></li>
<li class="menu__item is-leaf leaf contact-us"><a href="/page/contact-clash" title="" class="menu__link">Contact Us</a></li>
<li class="menu__item is-leaf leaf about-us"><a href="/page/about-clashmusiccom" title="" class="menu__link">About Us</a></li>
<li class="menu__item is-leaf leaf advertise"><a href="/page/advertise-with-clash" title="" class="menu__link">Advertise</a></li>
<li class="menu__item is-leaf leaf careers"><a href="http://www.clashmusic.com/page/clash-careers" title="" class="menu__link">Careers</a></li>
<li class="menu__item is-leaf leaf news-rss-feed"><a href="/feed/news" class="menu__link">News RSS Feed</a></li>
<li class="menu__item is-leaf last leaf privacy-cookies-policy"><a href="http://www.clashmusic.com/news/clash-privacy-notice-gdpr-data-policy" class="menu__link">Privacy &amp; Cookies Policy</a></li>
</ul>
</div>
</div>
</section>
</div>
</div>
<script src="https://www.clashmusic.com/sites/all/modules/addthis/addthis.js?r0yqta"></script>
<script src="https://www.clashmusic.com/sites/all/modules/dfp_lazy_load/js/dfp-lazy-load.js?r0yqta"></script>

<script>var clicky_site_ids = clicky_site_ids || []; clicky_site_ids.push(101173899);</script>
<script async src="//static.getclicky.com/js"></script>
<noscript><p><img alt="Clicky" width="1" height="1" src="//in.getclicky.com/101173899ns.gif" /></p></noscript>


<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5124d1254681674a"></script>
<script type="text/javascript" src="https://s.skimresources.com/js/193370X1670807.skimlinks.js"></script>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"69e41e7e8b7e5962","version":"2021.9.0","r":1,"token":"8eeec4be8cd34a85b23afb3c98d5a257","si":100}'></script>
</body>
</html>
